summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot/certbot-9999.ebuild')
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild78
1 files changed, 46 insertions, 32 deletions
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index f5147fca7936..987d94f3776a 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -1,48 +1,62 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+EAPI=8
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi
-S=${WORKDIR}/${P}/${PN}
-inherit distutils-r1
-
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
RDEPEND="
- ${CDEPEND}
- >=app-crypt/acme-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
>=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
-
-python_prepare_all() {
- # required as deps of deps can trigger this too...
- echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
- distutils-r1_python_prepare_all
-}