summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/cfssl/cfssl-1.6.0.ebuild')
-rw-r--r--app-crypt/cfssl/cfssl-1.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/cfssl/cfssl-1.6.0.ebuild b/app-crypt/cfssl/cfssl-1.6.0.ebuild
new file mode 100644
index 000000000000..3d244721ab37
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.1-build-fix.patch"
+)
+
+src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG README.md
+}