summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
new file mode 100644
index 000000000000..547d41918d4e
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="GnuPG archive keys of the Debian archive"
+HOMEPAGE="https://packages.debian.org/sid/debian-archive-keyring"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+
+ # https://bugs.gentoo.org/729142
+ gunzip "${D}"/usr/share/doc/${PN}/changelog.gz || die
+
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}