summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/eid-mw/eid-mw-9999.ebuild')
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild67
1 files changed, 37 insertions, 30 deletions
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index 57bb7b83b7df..c5f5f8f7995c 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit autotools mozextension
+inherit eutils autotools mozextension multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
@@ -12,10 +12,9 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
SRC_URI=""
else
- MY_P="${P}-v${PV}"
- SRC_URI="https://downloads.services.belgium.be/eid/${MY_P}.tar.gz"
+ SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} ->
+ ${P}.tar.gz"
KEYWORDS="~x86 ~amd64 ~arm"
- S="${WORKDIR}/${MY_P}"
fi
SLOT="0"
@@ -24,17 +23,22 @@ DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal
HOMEPAGE="http://eid.belgium.be"
-IUSE="+gtk +xpi +dialogs"
+IUSE="+dialogs +gtk p11-kit +xpi"
REQUIRED_USE="
dialogs? ( gtk )"
-RDEPEND="gtk? ( x11-libs/gtk+:= )
+RDEPEND="gtk? (
+ x11-libs/gtk+:*
+ dev-libs/libxml2
+ net-misc/curl[ssl]
+ net-libs/libproxy
+ !app-misc/eid-viewer-bin
+ )
>=sys-apps/pcsc-lite-1.2.9
- net-libs/libproxy
+ p11-kit? ( app-crypt/p11-kit )
xpi? ( || ( >=www-client/firefox-bin-3.6.24
- >=www-client/firefox-3.6.20 ) )
- !app-misc/beid-runtime"
+ >=www-client/firefox-3.6.20 ) )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -42,28 +46,30 @@ DEPEND="${RDEPEND}
src_prepare() {
eapply_user
+ sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
+ sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
+
+ # hardcoded lsb_info
+ sed -i \
+ -e "s:get_lsb_info('i'):strdup(_(\"Gentoo\")):" \
+ -e "s:get_lsb_info('r'):strdup(_(\"n/a\")):" \
+ -e "s:get_lsb_info('c'):strdup(_(\"n/a\")):" \
+ plugins_tools/aboutmw/gtk/about-main.c || die
+
if [[ ${PV} == "9999" ]] ; then
use gtk || eapply "${FILESDIR}"/gtk_not_required_9999.patch
-
- # Only in current git. Hopefully, in next release.
- sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
- sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
else
- use gtk || eapply "${FILESDIR}"/gtk_not_required_4.1.4.patch
- fi
-
- if [[ ${PV} == "9999" ]] || ! use gtk ; then
- eautoreconf
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_4_2.patch
fi
- # Do that after autoreconf (if autoreconf is required)
- # This patch is not mandatory, it's just to do things properly :-)
- eapply "${FILESDIR}"/not_zip_xpi_plugin.patch
+ eautoreconf
}
src_configure() {
econf \
$(use_enable dialogs) \
+ $(use_enable p11-kit p11kit) \
+ --with-gnu-ld \
--disable-static \
--disable-signed
}
@@ -71,21 +77,22 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install
- if [[ ${PV} != "9999" ]] ; then
- # Automatically done in current git. Hopefully, in next release.
- rm doc/sdk/include/rsaref220/win32.h || die
- doheader -r doc/sdk/include/*
- fi
if use xpi; then
declare MOZILLA_FIVE_HOME
if has_version '>=www-client/firefox-3.6.20'; then
MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
- xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
fi
if has_version '>=www-client/firefox-bin-3.6.24'; then
MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
fi
fi
- rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la || die
+ rm -r "${D}/usr/share/mozilla" "${D}"/usr/$(get_libdir)/*.la || die
+ use gtk || rm -r "${D}/usr/include/eid-util" || die
+}
+
+pkg_postinst()
+{
+ use gtk && glib-compile-schemas /usr/share/glib-2.0/schemas/
}