summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/envchain/envchain-1.0.1.ebuild')
-rw-r--r--app-crypt/envchain/envchain-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-crypt/envchain/envchain-1.0.1.ebuild b/app-crypt/envchain/envchain-1.0.1.ebuild
new file mode 100644
index 000000000000..2fbc68f9cb3b
--- /dev/null
+++ b/app-crypt/envchain/envchain-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Save environment variables in a secret vault"
+HOMEPAGE="https://github.com/sorah/envchain"
+SRC_URI="https://github.com/sorah/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/readline:0=
+ app-crypt/libsecret"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+}