summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/kbfs/kbfs-1.0.36.ebuild')
-rw-r--r--app-crypt/kbfs/kbfs-1.0.36.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/kbfs/kbfs-1.0.36.ebuild b/app-crypt/kbfs/kbfs-1.0.36.ebuild
new file mode 100644
index 000000000000..b084faeb8f15
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-1.0.36.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+EGIT_REPO_URI="https://github.com/keybase/kbfs.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="git"
+
+DEPEND="
+ >=dev-lang/go-1.6:0
+ >=app-crypt/keybase-1.0.17
+ "
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse
+ "
+
+S="${WORKDIR}/src/github.com/keybase/kbfs"
+
+src_unpack() {
+ git-r3_src_unpack
+ mkdir -p "$(dirname "${S}")" || die
+ ln -s "${WORKDIR}/${P}" "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/kbfsfuse" \
+ github.com/keybase/kbfs/kbfsfuse
+ use git && \
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/git-remote-keybase" \
+ github.com/keybase/kbfs/kbfsgit/git-remote-keybase
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ use git && \
+ dobin "${T}/git-remote-keybase"
+}