summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/keybase/keybase-1.0.9.0.ebuild')
-rw-r--r--app-crypt/keybase/keybase-1.0.9.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-crypt/keybase/keybase-1.0.9.0.ebuild b/app-crypt/keybase/keybase-1.0.9.0.ebuild
deleted file mode 100644
index 184ba0ab123b..000000000000
--- a/app-crypt/keybase/keybase-1.0.9.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils versionator
-
-MY_PV=$(replace_version_separator 3 '-')
-
-DESCRIPTION="Client for keybase.io"
-HOMEPAGE="https://keybase.io/"
-SRC_URI="https://github.com/keybase/client/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- >=dev-lang/go-1.5:0"
-RDEPEND="
- app-crypt/gnupg"
-
-S="${WORKDIR}/src/github.com/keybase/client"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- mkdir -p "$(dirname "${S}")" || die
- mv "client-${MY_PV}" "${S}" || die
-}
-
-src_compile() {
- GO15VENDOREXPERIMENT=1 \
- GOPATH="${WORKDIR}:${S}/go/vendor" \
- go build -v -x \
- -tags production \
- -o "${T}/keybase" \
- github.com/keybase/client/go/keybase || die
-}
-
-src_install() {
- dobin "${T}/keybase"
-}