summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/kstart/kstart-4.3.ebuild')
-rw-r--r--app-crypt/kstart/kstart-4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/kstart/kstart-4.3.ebuild b/app-crypt/kstart/kstart-4.3.ebuild
new file mode 100644
index 000000000000..93d710527a2e
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets automatically"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/kstart/"
+SRC_URI="https://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ sys-apps/keyutils
+ afs? ( net-fs/openafs )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ --with-libkeyutils \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS TODO examples/*
+}