summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libmd/libmd-1.0.4.ebuild')
-rw-r--r--app-crypt/libmd/libmd-1.0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/libmd/libmd-1.0.4.ebuild b/app-crypt/libmd/libmd-1.0.4.ebuild
new file mode 100644
index 000000000000..1cae95fb395f
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-version-script-linker-support-detection.patch"
+)
+
+src_prepare() {
+ default
+
+ # Drop on next release, only needed for lld patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}