summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/dehydrated/Manifest1
-rw-r--r--app-crypt/dehydrated/dehydrated-0.6.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/dehydrated/Manifest b/app-crypt/dehydrated/Manifest
index 135968836426..b2e1dad8e1ea 100644
--- a/app-crypt/dehydrated/Manifest
+++ b/app-crypt/dehydrated/Manifest
@@ -1,3 +1,4 @@
DIST dehydrated-0.3.1.tar.gz 71375 BLAKE2B 9ab014d0a4cc744081bd8aa134c460408da7f9936f1c41ef890bcebc70282fa61828620be3850cbb02f5b59b4e4fd32bdc41395340aa3673f906f154ca0877b9 SHA512 34b57edc6ab950c2c0163795ef45d6fa104dcf02978bbfa325da63f7d844176ecf20cb8d7604cfedc6b2f47d8c12ce1db5b37f532eda7fffa194b4603e4ee3b9
DIST dehydrated-0.4.0.tar.gz 74005 BLAKE2B ad55b7c53be0bc0c08ff372171638e9739a6213062b45c36e6ca5bce205b35d097bcffb6d1db6cd9c01f46a6ea31143cd2713bffb5e19f91041969e96a3cc337 SHA512 3c8c0f2fab57a432b69451f8372c02666dd953985679d12a2af9f6b917335b5b10a1196699106e317660039178ce1139a4d5455d4825a152b6911596fba16738
DIST dehydrated-0.6.1.tar.gz 76693 BLAKE2B 5ecca2942aedc024e87e7b5aac05d836adbbc8bb1dfb38bfcd396a63e9d3e8637d625e279c4e5a47514c0b4f27006226dad7257a620da49c426c256e5267a33d SHA512 c3ef92da4e0e12100d267422eb2667607842f6fb0fe10cbc4d10aee9b5137d292db2348eca34b1f492e21c6c325dcbb595a9ab4de634e4d4a43346be1e2ce0ad
+DIST dehydrated-0.6.2.tar.gz 77819 BLAKE2B 5a1cc097b42d5c4d9513b5a13c86f0b101b3442fb6cfbe54563357095619764724a2158e050a8e8b13a60a9effe83a5339ec647ef5a93622c8d63f1fcdb72be8 SHA512 97cce8f4936482d6b3a7d4227d8735b1c91f3b6cb7c728669a4a5139605932a88171c7e5d715d269782f260454d06ee95a0f6cd2735521e22c4f69bdc3e38f86
diff --git a/app-crypt/dehydrated/dehydrated-0.6.2.ebuild b/app-crypt/dehydrated/dehydrated-0.6.2.ebuild
new file mode 100644
index 000000000000..6e6825c0b177
--- /dev/null
+++ b/app-crypt/dehydrated/dehydrated-0.6.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="a client for signing certificates with an ACME-server"
+HOMEPAGE="https://github.com/lukas2511/dehydrated"
+SRC_URI="mirror://github.com/lukas2511/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/cron"
+RDEPEND="
+ ${DEPEND}
+ app-shells/bash
+ net-misc/curl
+"
+
+src_configure() {
+ default
+ sed -i 's,^#CONFIG_D=.*,CONFIG_D="/etc/dehydrated/config.d",' docs/examples/config || die "could not set config (CONFIG_D)"
+}
+
+src_install() {
+ dobin "${PN}"
+ insinto "/etc/${PN}"
+ doins docs/examples/{config,domains.txt,hook.sh}
+ dodoc docs/*.md
+
+ insinto /etc/"${PN}"/config.d
+ doins "${FILESDIR}"/00_gentoo.sh
+
+ insinto "/etc/cron.d"
+ newins "${FILESDIR}"/cron "${PN}"
+
+ dodir /etc/"${PN}"/config.d
+ keepdir /etc/"${PN}"/config.d
+
+ default
+}
+
+pkg_preinst() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 -1 /var/lib/"${PN}" "${PN}"
+}
+
+pkg_postinst() {
+ if [[ "${REPLACING_VERSIONS}" =~ (0\.3\.1|0\.4\.0) ]]; then
+ ewarn ""
+ ewarn "The new default BASEDIR is now '/var/lib/dehydrated'"
+ ewarn "Please consider migrating your data with a command like"
+ ewarn ""
+ ewarn " 'mv -v /etc/dehydrated/{accounts,archive,certs,lock} /var/lib/dehydrated'"
+ ewarn ""
+ ewarn "and make sure BASEDIR is set to '/var/lib/dehydrated'"
+ ewarn ""
+ fi
+ einfo "See /etc/dehydrated/config for configuration."
+ einfo "After finishing setup you should enable the cronjob in /etc/cron.d/dehydrated."
+}