summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/easy-rsa/Manifest1
-rw-r--r--app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/easy-rsa/Manifest b/app-crypt/easy-rsa/Manifest
index 473d5fff2a0d..a6574d430ccf 100644
--- a/app-crypt/easy-rsa/Manifest
+++ b/app-crypt/easy-rsa/Manifest
@@ -1,2 +1,3 @@
DIST EasyRSA-3.0.4.tgz 37721 BLAKE2B 84d81eb86dfee42f6de935cbd308262d36626170880a24d260dd8ae708d6340feb63866cb1704c9209675112eef4a251399e19948e88067e90b410c00707a770 SHA512 0bc145e510891af022c05427436c3ec7a29fce9d83e022954acd0cc470c88c43f5549af0b6263b46e8dc5fd167621a118cba0c01a514c51032cea8f1efbb9787
DIST easy-rsa-3.0.5.tar.gz 638366 BLAKE2B 990ef0cc7effd80d06d15dbb2dc3ef9a0a282a4adb501475fbd43c1b50bead374ba78ee9652e9c0f8d2e54354be4da6a0ae302e4ef2d576bd7fd981d59566d64 SHA512 9231ca7fda489a230d8418679d8824503ae680e2de6682d5f2d2fa716597f7df5980b7b88a3f6eb4fa0b7d9bbead59a1e2e4b8f4a5a36bda7f78ffa8f3c23d34
+DIST easy-rsa-3.0.6.tar.gz 663190 BLAKE2B 2c7f526c3ddddf13b4c6193bcd52bc992b9e81db28dec8cd9b5f44aba231eed18b6f25c64a42072a6409a5dd23db21fa8ccefc210ce924c68ad3a79475d2eaa1 SHA512 ce553b483ed2facab71d9bc212c4a454c6ed4a6489a0b963c4fc190916c71d048955e1e24d3e58a39438a51a83a02bf696bb2b9292c6ff665113043509062eb1
diff --git a/app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild b/app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild
new file mode 100644
index 000000000000..f827f0cc84ee
--- /dev/null
+++ b/app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small RSA key management package, based on OpenSSL"
+HOMEPAGE="https://openvpn.net/"
+SRC_URI="https://github.com/OpenVPN/easy-rsa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ !<net-vpn/openvpn-2.3"
+
+src_install() {
+ exeinto /usr/share/easy-rsa
+ doexe easyrsa3/easyrsa
+ insinto /usr/share/easy-rsa
+ doins -r easyrsa3/{vars.example,openssl-easyrsa.cnf,x509-types}
+ dodoc README.quickstart.md ChangeLog
+ dodoc -r doc
+ doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
+}