summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/nitrokey-app/Manifest1
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-1.4.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/nitrokey-app/Manifest b/app-crypt/nitrokey-app/Manifest
index 6d3cda96e370..5e241aa5e885 100644
--- a/app-crypt/nitrokey-app/Manifest
+++ b/app-crypt/nitrokey-app/Manifest
@@ -1 +1,2 @@
+DIST nitrokey-app-1.4.2.tar.gz 1204482 BLAKE2B 27490295300ec47c58425f4009e0be8038844c76e03cfc4725a2e9f6c43eebf949ecda4d0593eb62a0ebee9af387d26606c53d22ff97ccd32f978df2a5e3d0d8 SHA512 48234e9ab594d52123c7d3f538f1520bf21e0be81acacd1dbddc96727ae148ef2840a29bf165c566eb03ed4bef2203eb616db1f157652e0b896125d3fe524f53
DIST nitrokey-app-1.4.tar.gz 1205541 BLAKE2B 3e2e3ed85aff85168f9669cd16df026cc2108c601998222f6f6411b19bc4f027541e2c9368f50d383c21bdf2f38d19c69559616d89f5736d4634973d686f2310 SHA512 e0a29bd312b5f8bd1a5bd09ac118b9191a9261341e31f59d355e119fce488c23978af804113f96a93d1b5301ad17e53c2cfaefc9f5ec3b37fdd1ba304325f8a9
diff --git a/app-crypt/nitrokey-app/nitrokey-app-1.4.2.ebuild b/app-crypt/nitrokey-app/nitrokey-app-1.4.2.ebuild
new file mode 100644
index 000000000000..fbcae50c1f6b
--- /dev/null
+++ b/app-crypt/nitrokey-app/nitrokey-app-1.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 xdg cmake
+
+DESCRIPTION="Cross platform personalization tool for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/nitrokey-app"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/nitrokey-app"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/libnitrokey-3.5:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/cppcodec"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=( -DBASH_COMPLETION_PATH="$(get_bashcompdir)" )
+ cmake_src_configure
+}