summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/ipadic')
-rw-r--r--app-dicts/ipadic/Manifest1
-rw-r--r--app-dicts/ipadic/files/ipadic-2.7.0-gentoo.patch33
-rw-r--r--app-dicts/ipadic/files/ipadic-2.7.0-r2-gentoo.patch30
-rw-r--r--app-dicts/ipadic/ipadic-2.7.0-r2.ebuild31
-rw-r--r--app-dicts/ipadic/metadata.xml8
5 files changed, 103 insertions, 0 deletions
diff --git a/app-dicts/ipadic/Manifest b/app-dicts/ipadic/Manifest
new file mode 100644
index 000000000000..6b227be5e631
--- /dev/null
+++ b/app-dicts/ipadic/Manifest
@@ -0,0 +1 @@
+DIST ipadic-2.7.0.tar.gz 4300102 SHA256 ba2744cc16142159b330075e13eed4565908915ac95a790d38dea540e0963c1c SHA512 0c4617733d3a786f4a9d0773c50cd76da5433921dc4eb4f759b8b3c0fd3c0db411696068ee795a893063e1a7ab1bdb6afc740331c5fdd2c3ebc914324f4e33c3 WHIRLPOOL 95998a03c3cb0d5162028723e55afb400b58f1db8d52e44bc91d58007609cb57410bf8bf5b32bd623c67b417203dc0b0d474e8c0f9e639ada8c566ef83f29dd7
diff --git a/app-dicts/ipadic/files/ipadic-2.7.0-gentoo.patch b/app-dicts/ipadic/files/ipadic-2.7.0-gentoo.patch
new file mode 100644
index 000000000000..159684a96d96
--- /dev/null
+++ b/app-dicts/ipadic/files/ipadic-2.7.0-gentoo.patch
@@ -0,0 +1,33 @@
+--- ipadic-2.7.0.orig/Makefile.am 2003-09-13 14:37:17.000000000 +0900
++++ ipadic-2.7.0/Makefile.am 2010-03-21 09:25:48.000000000 +0900
+@@ -11,18 +11,22 @@
+ EXTRA_DIST = $(pre_data) $(lexical_dic) $(manual_files) @PACKAGE@.spec
+ CLEANFILES = $(gen_data)
+ #
+-matrix.cha table.cha:
++matrix.cha table.cha: makemat.done
++makemat.done:
+ $(MKDICDIR)/makemat
++ touch makemat.done
+
+-chadic.da:
++chadic.da chadic.dat chadic.lex: makeda.done
++makeda.done:
+ $(MKDICDIR)/makeda chadic *.dic
++ touch makeda.done
+
+-install-data-local:
+- if test -f @CHASEN_CHASENRC_PATH@ ; then \
+- echo "Please modify @CHASEN_CHASENRC_PATH@"; \
+- else \
+- cp chasenrc @CHASEN_CHASENRC_PATH@ ;\
+- fi
++#install-data-local:
++# if test -f @CHASEN_CHASENRC_PATH@ ; then \
++# echo "Please modify @CHASEN_CHASENRC_PATH@"; \
++# else \
++# cp chasenrc @CHASEN_CHASENRC_PATH@ ;\
++# fi
+
+ sjis-dist: dist
+ gtar xzvf ipadic-@VERSION@.tar.gz
diff --git a/app-dicts/ipadic/files/ipadic-2.7.0-r2-gentoo.patch b/app-dicts/ipadic/files/ipadic-2.7.0-r2-gentoo.patch
new file mode 100644
index 000000000000..8c701a363ec5
--- /dev/null
+++ b/app-dicts/ipadic/files/ipadic-2.7.0-r2-gentoo.patch
@@ -0,0 +1,30 @@
+diff -Naur ipadic-2.7.0.orig/Makefile.am ipadic-2.7.0/Makefile.am
+--- ipadic-2.7.0.orig/Makefile.am 2003-09-13 14:37:17.000000000 +0900
++++ ipadic-2.7.0/Makefile.am 2011-09-02 11:03:33.044589641 +0900
+@@ -11,18 +11,18 @@
+ EXTRA_DIST = $(pre_data) $(lexical_dic) $(manual_files) @PACKAGE@.spec
+ CLEANFILES = $(gen_data)
+ #
+-matrix.cha table.cha:
++matrix.cha table.cha chadic.lex chadic.dat:
+ $(MKDICDIR)/makemat
+
+-chadic.da:
++chadic.da: table.cha
+ $(MKDICDIR)/makeda chadic *.dic
+
+-install-data-local:
+- if test -f @CHASEN_CHASENRC_PATH@ ; then \
+- echo "Please modify @CHASEN_CHASENRC_PATH@"; \
+- else \
+- cp chasenrc @CHASEN_CHASENRC_PATH@ ;\
+- fi
++#install-data-local:
++# if test -f @CHASEN_CHASENRC_PATH@ ; then \
++# echo "Please modify @CHASEN_CHASENRC_PATH@"; \
++# else \
++# cp chasenrc @CHASEN_CHASENRC_PATH@ ;\
++# fi
+
+ sjis-dist: dist
+ gtar xzvf ipadic-@VERSION@.tar.gz
diff --git a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
new file mode 100644
index 000000000000..92f7635b4833
--- /dev/null
+++ b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit autotools eutils
+
+DESCRIPTION="Japanese dictionary for ChaSen"
+HOMEPAGE="http://sourceforge.jp/projects/ipadic/"
+SRC_URI="mirror://sourceforge.jp/${PN}/24435/${P}.tar.gz"
+
+LICENSE="ipadic"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=app-text/chasen-2.3.1"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PF}-gentoo.patch"
+ eautoreconf
+}
+
+src_install () {
+ default
+
+ insinto /etc
+ doins chasenrc
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/app-dicts/ipadic/metadata.xml b/app-dicts/ipadic/metadata.xml
new file mode 100644
index 000000000000..678b58f1d042
--- /dev/null
+++ b/app-dicts/ipadic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="sourceforge-jp">ipadic</remote-id>
+ </upstream>
+</pkgmetadata>