summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/doxygen-1.8.17.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.8.17.ebuild138
1 files changed, 0 insertions, 138 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.17.ebuild b/app-doc/doxygen/doxygen-1.8.17.ebuild
deleted file mode 100644
index fa827205e921..000000000000
--- a/app-doc/doxygen/doxygen-1.8.17.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-CMAKE_MAKEFILE_GENERATOR="emake"
-
-inherit cmake-utils eutils flag-o-matic llvm python-any-r1
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
- SRC_URI=""
-else
- SRC_URI="http://doxygen.nl/files/${P}.src.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Documentation system for most programming languages"
-HOMEPAGE="http://www.doxygen.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="clang debug doc dot doxysearch qt5 sqlite userland_GNU"
-
-RDEPEND="app-text/ghostscript-gpl
- dev-lang/perl
- media-libs/libpng:0=
- virtual/libiconv
- clang? ( <sys-devel/clang-10:= )
- dot? (
- media-gfx/graphviz
- media-libs/freetype
- )
- doc? (
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- doxysearch? ( dev-libs/xapian:= )
- qt5? (
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- )
- sqlite? ( dev-db/sqlite:3 )
- "
-
-DEPEND="sys-devel/flex
- sys-devel/bison
- doc? ( ${PYTHON_DEPS} )
- ${RDEPEND}"
-
-# src_test() defaults to make -C testing but there is no such directory (bug #504448)
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
- "${FILESDIR}/${PN}-1.8.16-link_with_pthread.patch"
- "${FILESDIR}/${PN}-1.8.15-llvm7.patch" #666692
- "${FILESDIR}/${PN}-1.8.17-ensure_static_support_libraries.patch"
-)
-
-DOCS=( LANGUAGE.HOWTO README.md )
-
-LLVM_MAX_SLOT=9
-
-pkg_setup() {
- use clang && llvm_pkg_setup
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # Ensure we link to -liconv
- if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
- local pro
- for pro in */*.pro.in */*/*.pro.in; do
- echo "unix:LIBS += -liconv" >> "${pro}" || die
- done
- fi
-
- # Call dot with -Teps instead of -Tps for EPS generation - bug #282150
- sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
-
- # fix pdf doc
- sed -i.orig -e "s:g_kowal:g kowal:" \
- doc/maintainers.txt || die
-
- if is-flagq "-O3" ; then
- ewarn
- ewarn "Compiling with -O3 is known to produce incorrectly"
- ewarn "optimized code which breaks doxygen."
- ewarn
- elog
- elog "Continuing with -O2 instead ..."
- elog
- replace-flags "-O3" "-O2"
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -Duse_libclang=$(usex clang)
- -Dbuild_doc=$(usex doc)
- -Dbuild_search=$(usex doxysearch)
- -Dbuild_wizard=$(usex qt5)
- -Duse_sqlite3=$(usex sqlite)
- -DGIT_EXECUTABLE="false"
- )
- use doc && mycmakeargs+=(
- -DDOC_INSTALL_DIR="share/doc/${P}"
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- if use doc; then
- export VARTEXFONTS="${T}/fonts" # bug #564944
-
- if ! use dot; then
- sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
- {Doxyfile,doc/Doxyfile} \
- || die "disabling dot failed"
- fi
- cmake-utils_src_make -C "${BUILD_DIR}" docs
- fi
-}
-
-src_install() {
- cmake-utils_src_install
-}