summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/dav/dav-0.8.5-r2.ebuild')
-rw-r--r--app-editors/dav/dav-0.8.5-r2.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/app-editors/dav/dav-0.8.5-r2.ebuild b/app-editors/dav/dav-0.8.5-r2.ebuild
index b04dad5486e8..7ca8b35cdd7e 100644
--- a/app-editors/dav/dav-0.8.5-r2.ebuild
+++ b/app-editors/dav/dav-0.8.5-r2.ebuild
@@ -1,32 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit toolchain-funcs
+EAPI=7
-DESCRIPTION="A minimal console text editor"
-HOMEPAGE="http://dav-text.sourceforge.net/"
+inherit toolchain-funcs
+DESCRIPTION="Minimal console text editor"
+HOMEPAGE="https://dav-text.sourceforge.net/"
# The maintainer does not keep sourceforge's mirrors up-to-date,
# so we point to the website's store of files.
-SRC_URI="http://dav-text.sourceforge.net/files/${P}.tar.gz"
+SRC_URI="https://dav-text.sourceforge.net/files/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha amd64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+BDEPEND="virtual/pkgconfig"
RDEPEND="sys-libs/ncurses:0="
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-asneeded.patch"
"${FILESDIR}/${P}-davrc-buffer-overflow.patch"
"${FILESDIR}/fix-Wformat-security-warnings.patch"
+ "${FILESDIR}/${PN}-0.8.5-fno-common.patch"
+ "${FILESDIR}/${PN}-0.8.5-makefile.patch"
)
+DOCS=( README )
+
# Makefile only
src_configure() { :; }
@@ -37,4 +39,7 @@ src_compile() {
LDFLAGS="${LDFLAGS} $( $(tc-getPKG_CONFIG) --libs ncurses)"
}
-DOCS=( README )
+src_install() {
+ default
+ docompress -x /usr/share/man/man1/dav.1.gz
+}