summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexcurse/hexcurse-1.60.0.ebuild')
-rw-r--r--app-editors/hexcurse/hexcurse-1.60.0.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/app-editors/hexcurse/hexcurse-1.60.0.ebuild b/app-editors/hexcurse/hexcurse-1.60.0.ebuild
index 95d897125147..913d53278aab 100644
--- a/app-editors/hexcurse/hexcurse-1.60.0.ebuild
+++ b/app-editors/hexcurse/hexcurse-1.60.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools
DESCRIPTION="ncurses based hex editor"
@@ -10,25 +11,19 @@ SRC_URI="https://github.com/LonnyGomes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha amd64 arm ~hppa ppc ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND=">=sys-libs/ncurses-5.2:0="
+DEPEND="${RDEPEND}"
-RDEPEND="
- >=sys-libs/ncurses-5.2:0=
-"
-DEPEND="
- ${RDEPEND}
-"
PATCHES=(
- "${FILESDIR}"/${PN}-1.60.0-Werror.patch
- "${FILESDIR}"/${PN}-1.60.0-tinfo.patch
+ "${FILESDIR}"/${P}-Werror.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-gcc10.patch
)
src_prepare() {
default
+ rm README.Irix || die
eautoreconf
}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc AUTHORS ChangeLog NEWS README
-}