summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/jupp/jupp-3.1_p40.ebuild')
-rw-r--r--app-editors/jupp/jupp-3.1_p40.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/jupp/jupp-3.1_p40.ebuild b/app-editors/jupp/jupp-3.1_p40.ebuild
new file mode 100644
index 000000000000..d8bdab27bf57
--- /dev/null
+++ b/app-editors/jupp/jupp-3.1_p40.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portable version of Joe's Own Editor"
+HOMEPAGE="https://www.mirbsd.org/jupp.htm"
+SRC_URI="https://www.mirbsd.org/MirOS/dist/${PN}/joe-${PV/_p/${PN}}.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( sys-libs/ncurses:0= )
+ !app-editors/joe"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+DOCS="HINTS INFO LIST NEWS README TODO"
+
+src_prepare() {
+ default
+ chmod +x configure || die
+}
+
+src_configure() {
+ econf \
+ --enable-search_libs \
+ --enable-termcap \
+ $(use_enable ncurses curses)
+}