summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kakoune/kakoune-2021.10.28.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2021.10.28.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2021.10.28.ebuild b/app-editors/kakoune/kakoune-2021.10.28.ebuild
new file mode 100644
index 000000000000..67d9bb162963
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2021.10.28.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake -C src all
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
+
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}