summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.3.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 4950cc631156..26d9e88a82c8 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,2 +1,3 @@
DIST neovim-0.2.0.tar.gz 7846467 BLAKE2B ee929122b3855ccab6247a0e8ab975b09d77e1034229ea324ed82ad705cacbd39f55d2fa96eea3f3677c7efe64c69ebecedd5fde09e508a6fd23acb6a1f5b489 SHA512 fc4be03c5bee1c9928376938679f9a900f3ee2e58df817d1cb9b5af51350dccca63a7638114b0326ec4565a047faaa4b50fecfc932c1d59ee92efa54625e22cd
DIST neovim-0.2.2.tar.gz 8325879 BLAKE2B dbf43c5927b8c8719adae9a3f73c57429de47f1b7c7489a118b7467df2f0d32cd02df8e10889727b4dd77fe8b4fb4f95520c678d6775d5d908705770a47cec0c SHA512 5609defe86ac98356f1b9ae9adc6049bb4df920a9a2ae3104f761d52d4dd54cbc84d2596231595dd9b0aa97201fef2121e6c5c86a19267ab6b871dbf4b568209
+DIST neovim-0.3.0.tar.gz 8903630 BLAKE2B 44936f0042be1771725a42168865d65f9afe048c116ed0d5f1542dffd8206a21dc4cbab1e08e97fdc27083251655c43df0451c5808ed6c6ad99eb2d582c55b9b SHA512 8944be5562a69d5da5bce3a6673cc0b1930eb5592eb15c40139a1991f89f63435141449e7b4371ee28ff426575fcad475396e3d982004e17a902bda1d8ae6a95
diff --git a/app-editors/neovim/neovim-0.3.0.ebuild b/app-editors/neovim/neovim-0.3.0.ebuild
new file mode 100644
index 000000000000..b25617fdef50
--- /dev/null
+++ b/app-editors/neovim/neovim-0.3.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
+
+CDEPEND=">=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-1.0.0
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? (
+ dev-lang/lua:=
+ dev-lua/LuaBitOp
+ )
+ tui? (
+ >=dev-libs/libtermkey-0.19
+ >=dev-libs/unibilium-1.1.1:=
+ )
+ dev-libs/libvterm
+ dev-lua/lpeg[luajit=]
+ dev-lua/mpack[luajit=]
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
+ virtual/libiconv
+ virtual/libintl"
+
+RDEPEND="
+ ${CDEPEND}
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+ remote? ( dev-python/neovim-remote )
+ clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/globals.h || die
+
+ # add eclass to bash filetypes
+ sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFEAT_TUI=$(usex tui)
+ -DENABLE_JEMALLOC=$(usex jemalloc)
+ -DPREFER_LUA=$(usex luajit no yes)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}