summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/xemacs-21.4.24-r1.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.4.24.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.5.34-r4.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/app-editors/xemacs/xemacs-21.4.24-r1.ebuild b/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
index 980a68d80e3d..6975de5d4292 100644
--- a/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
@@ -7,7 +7,7 @@
EAPI="5"
WANT_AUTOCONF="2.1"
-inherit autotools eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs xdg-utils
DESCRIPTION="highly customizable open source text editor and application development system"
HOMEPAGE="http://www.xemacs.org/"
@@ -233,9 +233,11 @@ src_install() {
pkg_postinst() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}
pkg_postrm() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}
diff --git a/app-editors/xemacs/xemacs-21.4.24.ebuild b/app-editors/xemacs/xemacs-21.4.24.ebuild
index 4c1eaa52fd03..a1297fa36999 100644
--- a/app-editors/xemacs/xemacs-21.4.24.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.24.ebuild
@@ -7,7 +7,7 @@
EAPI="5"
WANT_AUTOCONF="2.1"
-inherit autotools eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs xdg-utils
DESCRIPTION="highly customizable open source text editor and application development system"
HOMEPAGE="http://www.xemacs.org/"
@@ -235,9 +235,11 @@ src_install() {
pkg_postinst() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}
pkg_postrm() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}
diff --git a/app-editors/xemacs/xemacs-21.5.34-r4.ebuild b/app-editors/xemacs/xemacs-21.5.34-r4.ebuild
index d806967cce40..c060855e5924 100644
--- a/app-editors/xemacs/xemacs-21.5.34-r4.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.34-r4.ebuild
@@ -7,7 +7,7 @@
EAPI=5
WANT_AUTOCONF="2.5"
-inherit eutils flag-o-matic multilib
+inherit eutils flag-o-matic multilib xdg-utils
DESCRIPTION="highly customizable open source text editor and application development system"
HOMEPAGE="http://www.xemacs.org/"
@@ -235,6 +235,7 @@ src_install() {
pkg_postinst() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
einfo "If you are upgrading from XEmacs 21.4 you should note the following"
einfo "incompatibilities:"
@@ -252,4 +253,5 @@ pkg_postinst() {
pkg_postrm() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}