summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/files/zile-2.3.24-gets.patch30
-rw-r--r--app-editors/zile/zile-2.3.24-r1.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/app-editors/zile/files/zile-2.3.24-gets.patch b/app-editors/zile/files/zile-2.3.24-gets.patch
new file mode 100644
index 000000000000..9060c4bcf921
--- /dev/null
+++ b/app-editors/zile/files/zile-2.3.24-gets.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/623218
+Backported from gnulib in zile-2.4.11.
+
+--- zile-2.3.24-orig/lib/stdio.in.h
++++ zile-2.3.24/lib/stdio.in.h
+@@ -717,22 +717,11 @@
+ # endif
+ #endif
+
+-#if @GNULIB_GETS@
+-# if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
+-# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-# undef gets
+-# define gets rpl_gets
+-# endif
+-_GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
+-_GL_CXXALIAS_RPL (gets, char *, (char *s));
+-# else
+-_GL_CXXALIAS_SYS (gets, char *, (char *s));
+-# undef gets
+-# endif
+-_GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
++#undef gets
++#if HAVE_RAW_DECL_GETS
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
+
diff --git a/app-editors/zile/zile-2.3.24-r1.ebuild b/app-editors/zile/zile-2.3.24-r1.ebuild
index ebbf29d39946..a826b16dc353 100644
--- a/app-editors/zile/zile-2.3.24-r1.ebuild
+++ b/app-editors/zile/zile-2.3.24-r1.ebuild
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}-userhome.patch"
+ epatch "${FILESDIR}/${P}-gets.patch"
}
src_configure() {