summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/amx/amx-3.4.ebuild')
-rw-r--r--app-emacs/amx/amx-3.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/amx/amx-3.4.ebuild b/app-emacs/amx/amx-3.4.ebuild
new file mode 100644
index 000000000000..fa23093eb4a8
--- /dev/null
+++ b/app-emacs/amx/amx-3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Alternative M-x interface for GNU Emacs"
+HOMEPAGE="https://github.com/DarwinAwardWinner/amx/"
+SRC_URI="https://github.com/DarwinAwardWinner/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+# TODO: When ido is packaged: || ( app-emacs/ido app-emacs/ivy )
+RDEPEND="
+ app-emacs/s
+ app-emacs/ivy
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.mkdn )
+SITEFILE="50${PN}-gentoo.el"