summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/css-mode')
-rw-r--r--app-emacs/css-mode/Manifest1
-rw-r--r--app-emacs/css-mode/css-mode-0.11-r1.ebuild29
-rw-r--r--app-emacs/css-mode/files/50css-mode-gentoo.el3
-rw-r--r--app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch24
-rw-r--r--app-emacs/css-mode/metadata.xml5
5 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/css-mode/Manifest b/app-emacs/css-mode/Manifest
new file mode 100644
index 000000000000..a82f493e1e2c
--- /dev/null
+++ b/app-emacs/css-mode/Manifest
@@ -0,0 +1 @@
+DIST css-mode-0.11.tar.bz2 6848 SHA256 f7980d13a2d5ba2ac6873fdc2c7b54db5c13e93294a2c1068b4b04e7b6a2f7d4 SHA512 b93574fde8bb24ffc4dac6ddda20db3ec3c1834c1201f250f24805d31c7972edc2ffc157e7717327e7baac5c71a1d943a9d80bc7bec96be99c44cd2ab16e0e03 WHIRLPOOL e9036b4ef8604025aa123fc56c51b2171f0027d493134b89a96d2eceef3b0de3668c5ced5396c684b3ff8cfa595eb21d3ddd491a3c2b45f486955cee4f020b30
diff --git a/app-emacs/css-mode/css-mode-0.11-r1.ebuild b/app-emacs/css-mode/css-mode-0.11-r1.ebuild
new file mode 100644
index 000000000000..27ad064adb35
--- /dev/null
+++ b/app-emacs/css-mode/css-mode-0.11-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A major mode for editing Cascading Style Sheets (CSS)"
+HOMEPAGE="http://www.garshol.priv.no/download/software/css-mode/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+
+ELISP_PATCHES="${P}-no-compat-kbd.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ # Fix documentation
+ sed -i -e 's,HREF="/visuals/standard.css",HREF="standard.css",' doco.html
+}
+
+src_install() {
+ elisp_src_install
+ dohtml -A css doco.html standard.css
+}
diff --git a/app-emacs/css-mode/files/50css-mode-gentoo.el b/app-emacs/css-mode/files/50css-mode-gentoo.el
new file mode 100644
index 000000000000..8559be036db5
--- /dev/null
+++ b/app-emacs/css-mode/files/50css-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.css\\'" . css-mode))
+(autoload 'css-mode "css-mode" "Mode for editing Cascading Style Sheets" t)
diff --git a/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch b/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch
new file mode 100644
index 000000000000..858cb238bf3c
--- /dev/null
+++ b/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch
@@ -0,0 +1,24 @@
+Function "apropos-macrop" apparently no longer exists in Emacs 24.4.
+Simply remove the code using it, since it was only needed for backwards
+compatibility with Emacs 19 (the "kbd" macro appeared in Emacs 20.1).
+https://bugs.gentoo.org/532358
+
+--- css-mode-0.11-orig/css-mode.el
++++ css-mode-0.11/css-mode.el
+@@ -166,16 +166,6 @@
+ (define-key cssm-mode-map (read-kbd-macro "}") 'cssm-insert-right-brace-and-indent)
+ (define-key cssm-mode-map (read-kbd-macro "M-TAB") 'cssm-complete-property))
+
+-;;; Cross-version compatibility layer
+-
+-(when (not (or (apropos-macrop 'kbd)
+- (fboundp 'kbd)))
+- (defmacro kbd (keys)
+- "Convert KEYS to the internal Emacs key representation.
+-KEYS should be a string constant in the format used for
+-saving keyboard macros (see `insert-kbd-macro')."
+- (read-kbd-macro keys)))
+-
+ ;;; Auto-indentation support
+
+ ; internal
diff --git a/app-emacs/css-mode/metadata.xml b/app-emacs/css-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/css-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>