summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/cycle-buffer/cycle-buffer-2.16-r1.ebuild')
-rw-r--r--app-emacs/cycle-buffer/cycle-buffer-2.16-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/cycle-buffer/cycle-buffer-2.16-r1.ebuild b/app-emacs/cycle-buffer/cycle-buffer-2.16-r1.ebuild
new file mode 100644
index 000000000000..7158dd90fd07
--- /dev/null
+++ b/app-emacs/cycle-buffer/cycle-buffer-2.16-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Select buffer by cycling through"
+HOMEPAGE="https://www.emacswiki.org/emacs/cycle-buffer.el"
+# taken from https://www.emacswiki.org/emacs/download/cycle-buffer.el
+SRC_URI="https://github.com/gavv/distfiles/raw/master/${P}.el.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}