summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/dash/dash-2.12.0.ebuild')
-rw-r--r--app-emacs/dash/dash-2.12.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/dash/dash-2.12.0.ebuild b/app-emacs/dash/dash-2.12.0.ebuild
new file mode 100644
index 000000000000..ee1d25b38253
--- /dev/null
+++ b/app-emacs/dash/dash-2.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A modern list library for Emacs"
+HOMEPAGE="https://github.com/magnars/dash.el"
+SRC_URI="https://github.com/magnars/dash.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo dash.info
+ dodoc README.md
+}