summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/diff-hl/diff-hl-1.9.1.ebuild')
-rw-r--r--app-emacs/diff-hl/diff-hl-1.9.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/app-emacs/diff-hl/diff-hl-1.9.1.ebuild b/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
deleted file mode 100644
index 9f61253a182d..000000000000
--- a/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-[[ ${PV} == 1.9.1 ]] && COMMIT=8f2e4eb345f0639c8fc41e3f7576f77ba6987655
-
-inherit elisp
-
-DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
-HOMEPAGE="https://github.com/dgutov/diff-hl/"
-SRC_URI="https://github.com/dgutov/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COMMIT}
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( dev-vcs/git )"
-
-DOCS=( README.md screenshot{,-dired,-margin}.png )
-SITEFILE="50${PN}-gentoo.el"
-
-src_test() {
- ebegin "Creating a git repository for tests"
- git init "${S}" --initial-branch="master" &&
- git add "${S}" &&
- git config --local user.email "test@test" &&
- git config --local user.name "test" &&
- git commit --message "test" --quiet
- eend $? || die
- emake EMACS="${EMACS} ${EMACSFLAGS}" test
-}