summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/elpher')
-rw-r--r--app-emacs/elpher/Manifest1
-rw-r--r--app-emacs/elpher/elpher-3.4.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/elpher/Manifest b/app-emacs/elpher/Manifest
index bec38f8de3ef..fc79ff03d03f 100644
--- a/app-emacs/elpher/Manifest
+++ b/app-emacs/elpher/Manifest
@@ -1 +1,2 @@
DIST elpher-3.4.2.tar.gz 58546 BLAKE2B 34f0984a5533fa3049d57867214eb5000c08ca459cdaad61e08b031a1e09343697c7beaf6c83724f2b64fca85975cb27d4be16724a5a7cfb76f99c3bb048e937 SHA512 080eb9812cbcf4e72ba33272461f628892d8abc940328e6e14d56ad2a7bafb3740d75fa07b2693b9937303f9d8427531ea3aa95c228cbf53741c32cfd5408c84
+DIST elpher-3.4.3.tar.gz 58909 BLAKE2B 340efe11888c737b3cc8c7b428d302542030236b61cd0f86cce56e289203ea61ed8cb0a5da24e334ff8621bf3a679828ef8053d234410375484ddd3b63928b39 SHA512 53a9bf80df7c66c7f7453a60daf1c08f88228d03954bb638e703ac516001625be134ae530dd078ebe646ad922593b9ffa20daf325b23d299c65329216bbab4b2
diff --git a/app-emacs/elpher/elpher-3.4.3.ebuild b/app-emacs/elpher/elpher-3.4.3.ebuild
new file mode 100644
index 000000000000..211e305e5085
--- /dev/null
+++ b/app-emacs/elpher/elpher-3.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Practical and friendly Gopher and Gemini client for GNU Emacs"
+HOMEPAGE="https://thelambdalab.xyz/elpher/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://thelambdalab.xyz/${PN}.git"
+else
+ if [[ ${PV} == 3.4.3 ]] ; then
+ COMMIT=2f66d41
+ SRC_URI="https://thelambdalab.xyz/gitweb/index.cgi?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ die "could not generate SRC_URI"
+ fi
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+ELISP_REMOVE="elpher-pkg.el"
+
+DOCS=( ISSUES.org README )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"