summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild')
-rw-r--r--app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild b/app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild
new file mode 100644
index 000000000000..01ef92a64116
--- /dev/null
+++ b/app-emacs/emacs-el-fetch/emacs-el-fetch-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Show system information in Neofetch-like style inside Emacs"
+HOMEPAGE="https://gitlab.com/xgqt/emacs-el-fetch/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/xgqt/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+src_compile() {
+ emake compile
+}
+
+src_install() {
+ einstalldocs
+ elisp-install ${PN} "${S}"/src/el-fetch/*.el{,c}
+ elisp-site-file-install "${S}"/extras/gentoo/50el-fetch-gentoo.el
+}