summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pyvenv/pyvenv-1.21.ebuild')
-rw-r--r--app-emacs/pyvenv/pyvenv-1.21.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/pyvenv/pyvenv-1.21.ebuild b/app-emacs/pyvenv/pyvenv-1.21.ebuild
new file mode 100644
index 000000000000..c16f57b1102b
--- /dev/null
+++ b/app-emacs/pyvenv/pyvenv-1.21.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Python virtual environment interface for Emacs"
+HOMEPAGE="https://github.com/jorgenschaefer/pyvenv/"
+SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/mocker )"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # Other tests require special Python Venv setup
+ ${EMACS} ${EMACSFLAGS} -L . -l ./${PN}.el -L ./test \
+ -l ./test/pyvenv-mode-test.el -l ./test/pyvenv-hook-dir-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}