summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/teco')
-rw-r--r--app-emacs/teco/files/teco-7-backquotes.patch34
-rw-r--r--app-emacs/teco/teco-7-r2.ebuild3
2 files changed, 36 insertions, 1 deletions
diff --git a/app-emacs/teco/files/teco-7-backquotes.patch b/app-emacs/teco/files/teco-7-backquotes.patch
new file mode 100644
index 000000000000..b586812cf038
--- /dev/null
+++ b/app-emacs/teco/files/teco-7-backquotes.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/684180
+
+--- a/teco.el
++++ b/teco.el
+@@ -451,10 +451,10 @@
+ and does
+ (aset teco:exec-1 ?x 'teco:type-1-x)"
+ (let ((s (intern (concat "teco:type-1-" (char-to-string char)))))
+- (` (progn
+- (defun (, s) ()
+- (,@ body))
+- (aset teco:exec-1 (, char) '(, s))))))
++ `(progn
++ (defun ,s ()
++ ,@body)
++ (aset teco:exec-1 ,char ',s))))
+
+ (defmacro teco:define-type-2 (char &rest body)
+ "Define the code to process a type 2 character.
+@@ -467,10 +467,10 @@
+ and does
+ (aset teco:exec-2 ?x 'teco:type-2-x)"
+ (let ((s (intern (concat "teco:type-2-" (char-to-string char)))))
+- (` (progn
+- (defun (, s) ()
+- (,@ body))
+- (aset teco:exec-2 (, char) '(, s))))))
++ `(progn
++ (defun ,s ()
++ ,@body)
++ (aset teco:exec-2 ,char ',s))))
+
+ (defconst teco:char-types (make-vector 256 0)
+ "Define the characteristics of characters, as tested by \":
diff --git a/app-emacs/teco/teco-7-r2.ebuild b/app-emacs/teco/teco-7-r2.ebuild
index 921d8d072be2..3fedca3d015a 100644
--- a/app-emacs/teco/teco-7-r2.ebuild
+++ b/app-emacs/teco/teco-7-r2.ebuild
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
PATCHES=("${FILESDIR}"/${P}-minibuffer-prompt.patch
- "${FILESDIR}"/${P}-emacs-24.patch)
+ "${FILESDIR}"/${P}-emacs-24.patch
+ "${FILESDIR}"/${P}-backquotes.patch)
SITEFILE="50${PN}-gentoo.el"
DOC_CONTENTS="To be able to invoke Teco directly, define a keybinding
for teco:command in your ~/.emacs file, e.g.: