summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/transient/transient-0.3.5.ebuild')
-rw-r--r--app-emacs/transient/transient-0.3.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-0.3.5.ebuild b/app-emacs/transient/transient-0.3.5.ebuild
new file mode 100644
index 000000000000..5f2eb4af6a92
--- /dev/null
+++ b/app-emacs/transient/transient-0.3.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/transient"
+SRC_URI="https://github.com/magit/transient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="docs/*.texi"
+DOCS="README.md docs/transient.org"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}