summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ruby-mode/Manifest1
-rw-r--r--app-emacs/ruby-mode/files/50ruby-mode-gentoo-2.5.0.el12
-rw-r--r--app-emacs/ruby-mode/ruby-mode-2.5.0.ebuild18
3 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/ruby-mode/Manifest b/app-emacs/ruby-mode/Manifest
index bda428a80173..5988758504c9 100644
--- a/app-emacs/ruby-mode/Manifest
+++ b/app-emacs/ruby-mode/Manifest
@@ -2,3 +2,4 @@ DIST ruby-2.0.0-p247.tar.bz2 10804581 BLAKE2B b7f2f8234426361f7e53965ef93aada24f
DIST ruby-2.2.2.tar.xz 10463044 BLAKE2B 77e1bda547102da9aa47c1ca58c9c8189b204019605ca6363df678a4590fe59f63910a657bb653d605aab612351e09ba0384351e552c788fb6c54520fe9c6277 SHA512 bd72d0a4c017e2527659f64ef2781bbe8bd540a2302eaa60234a12282fd53c359e04205c56385402c67e81bb9dab3b88de53de82e12bb13e3386c26301043b64
DIST ruby-2.3.0.tar.xz 11294412 BLAKE2B 2c1324154aadd287952cc6430891048ea69922c063b1b2bac89b58603247eb09a79a8c527259d59ceabfc7be08ec2528c982bf2b0f1a223cf3e60d7a3934e8bc SHA512 d893c5e6db5a0533e0da48d899c619964388852ef90e7d1b92a4363d5f189cd2dba32a009581f62b9f42a8e6027975fc3c18b64faf356f5e3ac43a8d69ec5327
DIST ruby-2.4.1.tar.xz 9939188 BLAKE2B 5be893c8996d17ff333276a772747d3099cec0c41331e1a1916679afc43a8ad5ed99a827bc76b32652ec950eaec933dbe28e1dde313987c2891f258ba7097af7 SHA512 e6fd290b6edd166348b70f0f1c56f7ed9d956c4c1eb91d97d0548041ca4196b9b75ec1ad35c745bdbfd4de195899093e7205d7f02b014ecf1c48e6f31cf25903
+DIST ruby-2.5.0.tar.xz 11292472 BLAKE2B 852ce003a79d9d77e72928353382962440e99ed1d03558c89a928e8f4a582b27357ef63e3ef45f3b30009f7a95f356100941bd84151571ade3a88b2d0595f8ad SHA512 55714a33d7661fe8b432f73c34fd67b49699f8b79df1cbd680a74899124d31111ab0f444677672aac1ba725820182940d485efb2db0bf2bc96737c5d40c54578
diff --git a/app-emacs/ruby-mode/files/50ruby-mode-gentoo-2.5.0.el b/app-emacs/ruby-mode/files/50ruby-mode-gentoo-2.5.0.el
new file mode 100644
index 000000000000..691abdfdaf99
--- /dev/null
+++ b/app-emacs/ruby-mode/files/50ruby-mode-gentoo-2.5.0.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'ruby-mode "ruby-mode" "Major mode to edit ruby files." t)
+
+(add-to-list 'auto-mode-alist '("Rakefile\\'" . ruby-mode))
+(add-to-list 'auto-mode-alist '("\\.\\(rake\\|rb\\)\\'" . ruby-mode))
+(add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
+
+(autoload 'run-ruby "inf-ruby" "Run an inferior Ruby process" t)
+(autoload 'inf-ruby-keys "inf-ruby" "Set local key defs for inf-ruby in ruby-mode")
+
+(add-hook 'ruby-mode-hook 'inf-ruby-keys)
diff --git a/app-emacs/ruby-mode/ruby-mode-2.5.0.ebuild b/app-emacs/ruby-mode/ruby-mode-2.5.0.ebuild
new file mode 100644
index 000000000000..414ca4b0090d
--- /dev/null
+++ b/app-emacs/ruby-mode/ruby-mode-2.5.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Ruby code"
+HOMEPAGE="https://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/ruby-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+S="${WORKDIR}/ruby-${PV}/misc"
+DOCS="README"
+SITEFILE="50${PN}-gentoo-${PV}.el"