summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/a/Manifest1
-rw-r--r--app-emacs/a/a-1.0.0.ebuild29
-rw-r--r--app-emacs/a/files/50a-gentoo.el1
-rw-r--r--app-emacs/a/metadata.xml17
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/a/Manifest b/app-emacs/a/Manifest
new file mode 100644
index 000000000000..b0ee02ee81fd
--- /dev/null
+++ b/app-emacs/a/Manifest
@@ -0,0 +1 @@
+DIST a.el-1.0.0.tar.gz 19740 BLAKE2B c5bb72fd206b1b33798c90982f7111f7cd100e6e36580bce267b6d6295a82b536a00cddeed3cf9bf94964b451429769f705358a731cbe5054a2683fc90d4bf14 SHA512 3a795fb2cf613bafabbf2c788dc1edd4dbd26871043a9225f3db61542f1d5c95102355d9223498dc4dbe5aba446e9b8a22437b6e6799c3a0f2ad213bc35b2556
diff --git a/app-emacs/a/a-1.0.0.ebuild b/app-emacs/a/a-1.0.0.ebuild
new file mode 100644
index 000000000000..a6fe49e7363f
--- /dev/null
+++ b/app-emacs/a/a-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Associative data structure functions for Emacs Lisp"
+HOMEPAGE="https://github.com/plexus/a.el/"
+SRC_URI="https://github.com/plexus/a.el/archive/v${PV}.tar.gz
+ -> a.el-${PV}.tar.gz"
+S="${WORKDIR}"/a.el-${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
diff --git a/app-emacs/a/files/50a-gentoo.el b/app-emacs/a/files/50a-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/a/files/50a-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/a/metadata.xml b/app-emacs/a/metadata.xml
new file mode 100644
index 000000000000..3a987898ee9d
--- /dev/null
+++ b/app-emacs/a/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs Lisp functions for dealing with associative structures in a uniform
+ and functional way. Inspired by Clojure, dash, and seq.el.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/plexus/a.el/issues/</bugs-to>
+ <remote-id type="github">plexus/a.el</remote-id>
+ </upstream>
+</pkgmetadata>