summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/shrink-path/Manifest1
-rw-r--r--app-emacs/shrink-path/files/50shrink-path-gentoo.el1
-rw-r--r--app-emacs/shrink-path/metadata.xml13
-rw-r--r--app-emacs/shrink-path/shrink-path-0.3.1.ebuild43
4 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/shrink-path/Manifest b/app-emacs/shrink-path/Manifest
new file mode 100644
index 000000000000..1c0a8a217da4
--- /dev/null
+++ b/app-emacs/shrink-path/Manifest
@@ -0,0 +1 @@
+DIST shrink-path.el-v0.3.1.tar.bz2 15743 BLAKE2B 8f5db089737f2d31c9f5852265f1b33679de3cc72989bf04b8d50871b3b8fa356da6823177759561b99ee5b032fb10ba1c51f49cdd7d74daafb1d6cac44ba2b7 SHA512 f4cc191186c2a2e706ff08fbcd43f24dd67297a368c42da72626d70e3522d5b24ceba45a2e17821f6288576f10e0208e3d643946108edd6180502dd1bad019ed
diff --git a/app-emacs/shrink-path/files/50shrink-path-gentoo.el b/app-emacs/shrink-path/files/50shrink-path-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/shrink-path/files/50shrink-path-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/shrink-path/metadata.xml b/app-emacs/shrink-path/metadata.xml
new file mode 100644
index 000000000000..b46545666722
--- /dev/null
+++ b/app-emacs/shrink-path/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/bennya/shrink-path.el/-/issues/</bugs-to>
+ <remote-id type="gitlab">bennya/shrink-path.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shrink-path/shrink-path-0.3.1.ebuild b/app-emacs/shrink-path/shrink-path-0.3.1.ebuild
new file mode 100644
index 000000000000..b68e36a0c793
--- /dev/null
+++ b/app-emacs/shrink-path/shrink-path-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Fish-style path truncation for GNU Emacs"
+HOMEPAGE="https://gitlab.com/bennya/shrink-path.el/"
+SRC_URI="https://gitlab.com/bennya/${PN}.el/-/archive/v${PV}/${PN}.el-v${PV}.tar.bz2"
+S="${WORKDIR}"/${PN}.el-v${PV}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/s
+ app-emacs/dash
+ app-emacs/f
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i 's|it "same as shrink-path"|xit "same as shrink-path"|' \
+ "${S}"/test/shrink-path-test.el || die
+
+ default
+}
+
+src_test() {
+ buttercup -L . -L test --traceback full test || die
+}