summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/csharp-mode/Manifest1
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/Manifest b/app-emacs/csharp-mode/Manifest
index cf09a3d5a260..e903491c0640 100644
--- a/app-emacs/csharp-mode/Manifest
+++ b/app-emacs/csharp-mode/Manifest
@@ -1 +1,2 @@
DIST csharp-mode-0.7.0.tar.bz2 6254 SHA256 e72a17972283691c33080aaa60d8060576d2951f1e374da223cf76468bd2eeec SHA512 b6cbf2899853c29f44d19f37a01984a03c61f7bde144880f6f32e2a890d3b90a546ff69ad328d157e5494191aed37836373f49ddbafac49d8b9bd1cea3e22de9 WHIRLPOOL 58816ec16158adb4de40fe27540a3734813012ecd7f345fc048faa4807d85ecef9617d82e30f945ad7dfb1452ef066a1ed3e38c3e792e43940e23464ba70c552
+DIST v0.9.0.tar.gz 50453 SHA256 4232fe0fc4528be543ca1e338ce3e839814f2a5b43e480c16b7b4f1ea1bca3c5 SHA512 81661d98acdf03e01caf3b9388da8571e78402b8914755b223a38a723457a988201adcaf7b5b825c4e0126ad5e7628063f85dd4e60ee272102a5f1509f9446ef WHIRLPOOL c84d316b0160b092e5d368fc0020e9a05a2616b7da80cb8777dc7a80b7cbc19f79eeb5f112d6541343e468281958db4c3c1ee723c1b8443de93813bd6a636c81
diff --git a/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild b/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
new file mode 100644
index 000000000000..3a3494d568ff
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="https://github.com/josteink/csharp-mode"
+SRC_URI="https://github.com/josteink/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} csharp-mode.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org
+}