summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.9.12-r2.ebuild')
-rw-r--r--app-emulation/wine/wine-1.9.12-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.9.12-r2.ebuild b/app-emulation/wine/wine-1.9.12-r2.ebuild
index 4d1c5ee9ada4..f8713ef13c45 100644
--- a/app-emulation/wine/wine-1.9.12-r2.ebuild
+++ b/app-emulation/wine/wine-1.9.12-r2.ebuild
@@ -509,8 +509,10 @@ multilib_src_install_all() {
if ! use X && ! use ncurses; then
rm "${D}"/usr/bin/wineconsole* || die
rm "${D}"/usr/share/man/man1/wineconsole* || die
- use abi_x86_32 && rm "${D}"/usr/lib32/wine/{,fakedlls/}wineconsole.exe* || die
- use abi_x86_64 && rm "${D}"/usr/lib64/wine/{,fakedlls/}wineconsole.exe* || die
+ rm_wineconsole() {
+ rm "${D}usr/$(get_libdir)"/wine/{,fakedlls/}wineconsole.exe* || die
+ }
+ multilib_foreach_abi rm_wineconsole
fi
use abi_x86_32 && pax-mark psmr "${D}"usr/bin/wine{,-preloader} #255055