summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.9.4.ebuild')
-rw-r--r--app-emulation/wine/wine-1.9.4.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-emulation/wine/wine-1.9.4.ebuild b/app-emulation/wine/wine-1.9.4.ebuild
index 6388a5b6d1cb..e47fe62c7432 100644
--- a/app-emulation/wine/wine-1.9.4.ebuild
+++ b/app-emulation/wine/wine-1.9.4.ebuild
@@ -174,6 +174,20 @@ wine_build_environment_check() {
return 1
fi
fi
+ # bug #574044
+ if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) = 3 ]]; then
+ einfo "Checking for gcc-5-3 stack realignment compiler bug ..."
+ $(tc-getCC) -O2 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || die
+ # Run in subshell to prevent "Aborted" message
+ if ! ( "${T}"/69140 || false ) >/dev/null 2>&1; then
+ eerror "Wine cannot be built with this version of gcc-5.3"
+ eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
+ eerror "or use gcc-config to select a different compiler version."
+ eerror "See https://bugs.gentoo.org/574044"
+ eerror
+ return 1
+ fi
+ fi
if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then
eerror "You need gcc-4.4+ to build 64-bit wine"