summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/winetricks/winetricks-99999999.ebuild')
-rw-r--r--app-emulation/winetricks/winetricks-99999999.ebuild48
1 files changed, 19 insertions, 29 deletions
diff --git a/app-emulation/winetricks/winetricks-99999999.ebuild b/app-emulation/winetricks/winetricks-99999999.ebuild
index 58d2e71829ba..8c6edd07f67f 100644
--- a/app-emulation/winetricks/winetricks-99999999.ebuild
+++ b/app-emulation/winetricks/winetricks-99999999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit gnome2-utils eutils
+inherit desktop xdg
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="https://github.com/Winetricks/${PN}.git"
@@ -14,11 +14,12 @@ else
KEYWORDS="~amd64 ~x86"
fi
-wtg=winetricks-gentoo-2012.11.24
+wtg="winetricks-gentoo-2012.11.24"
SRC_URI="${SRC_URI}
gtk? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
- kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )"
+ kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
+"
DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winetricks"
@@ -27,13 +28,16 @@ LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="gtk kde rar test"
-DEPEND="test? (
+BDEPEND="
+ test? (
dev-python/bashate
dev-util/checkbashisms
dev-util/shellcheck
- )"
-
-RDEPEND="app-arch/cabextract
+ )
+"
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/cabextract
app-arch/p7zip
app-arch/unzip
net-misc/wget
@@ -41,7 +45,8 @@ RDEPEND="app-arch/cabextract
x11-misc/xdg-utils
gtk? ( gnome-extra/zenity )
kde? ( kde-apps/kdialog )
- rar? ( app-arch/unrar )"
+ rar? ( app-arch/unrar )
+"
# Test targets include syntax checks only, not the "heavy duty" tests
# that would require a lot of disk space, as well as network access.
@@ -53,11 +58,13 @@ RDEPEND="app-arch/cabextract
QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
+ if [[ ${PV} == "99999999" ]]; then
git-r3_src_unpack
+
if use gtk || use kde; then
unpack ${wtg}.tar.bz2
fi
+
else
default
fi
@@ -69,6 +76,7 @@ src_test() {
src_install() {
default
+
if use gtk || use kde; then
cd "${WORKDIR}/${wtg}" || die
domenu winetricks.desktop
@@ -76,21 +84,3 @@ src_install() {
doins wine-winetricks.svg
fi
}
-
-pkg_preinst() {
- if use gtk || use kde; then
- gnome2_icon_savelist
- fi
-}
-
-pkg_postinst() {
- if use gtk || use kde; then
- gnome2_icon_cache_update
- fi
-}
-
-pkg_postrm() {
- if use gtk || use kde; then
- gnome2_icon_cache_update
- fi
-}