summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/x48/files/x48-0.6.4-static.patch12
-rw-r--r--app-emulation/x48/files/x48-0.6.4-void_return.patch24
-rw-r--r--app-emulation/x48/x48-0.6.4-r2.ebuild12
3 files changed, 42 insertions, 6 deletions
diff --git a/app-emulation/x48/files/x48-0.6.4-static.patch b/app-emulation/x48/files/x48-0.6.4-static.patch
new file mode 100644
index 000000000000..f832e877b76e
--- /dev/null
+++ b/app-emulation/x48/files/x48-0.6.4-static.patch
@@ -0,0 +1,12 @@
+diff -Naur x48-0.6.4.orig/src/emulate.c x48-0.6.4/src/emulate.c
+--- x48-0.6.4.orig/src/emulate.c 2011-11-15 04:03:40.000000000 +0100
++++ x48-0.6.4/src/emulate.c 2020-06-23 21:30:30.895538239 +0200
+@@ -695,7 +695,7 @@
+ }
+ }
+
+-inline int
++static inline int
+ #ifdef __FunctionProto__
+ decode_8_thru_f(int op1)
+ #else
diff --git a/app-emulation/x48/files/x48-0.6.4-void_return.patch b/app-emulation/x48/files/x48-0.6.4-void_return.patch
new file mode 100644
index 000000000000..521ab6cd0546
--- /dev/null
+++ b/app-emulation/x48/files/x48-0.6.4-void_return.patch
@@ -0,0 +1,24 @@
+diff -Naur x48-0.6.4.orig/src/debugger.c x48-0.6.4/src/debugger.c
+--- x48-0.6.4.orig/src/debugger.c 2011-11-15 04:03:40.000000000 +0100
++++ x48-0.6.4/src/debugger.c 2020-06-23 21:33:16.071667987 +0200
+@@ -1528,7 +1528,7 @@
+ struct se *se_next;
+ };
+
+-char *
++void
+ #ifdef __FunctionProto__
+ get_stack (void)
+ #else
+diff -Naur x48-0.6.4.orig/src/x48_x11.c x48-0.6.4/src/x48_x11.c
+--- x48-0.6.4.orig/src/x48_x11.c 2011-11-15 04:03:40.000000000 +0100
++++ x48-0.6.4/src/x48_x11.c 2020-06-23 21:33:32.132680745 +0200
+@@ -3833,7 +3833,7 @@
+
+ int last_button = -1;
+
+-extern char *get_stack(void);
++extern void get_stack(void);
+
+ int
+ #ifdef __FunctionProto__
diff --git a/app-emulation/x48/x48-0.6.4-r2.ebuild b/app-emulation/x48/x48-0.6.4-r2.ebuild
index 47413f324968..9e603e25e582 100644
--- a/app-emulation/x48/x48-0.6.4-r2.ebuild
+++ b/app-emulation/x48/x48-0.6.4-r2.ebuild
@@ -22,15 +22,15 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
x11-libs/libXt"
-src_unpack() {
- mkdir -p "${S}"
- cd "${S}"
- unpack ${A}
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-static.patch
+ "${FILESDIR}"/${P}-void_return.patch
+ )
+
+S=${WORKDIR}
src_prepare() {
default
- sed -i '698s/inline/static inline/' src/emulate.c || die
eautoreconf
}