summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/slirp4netns/Manifest2
-rw-r--r--app-emulation/slirp4netns/metadata.xml19
-rw-r--r--app-emulation/slirp4netns/slirp4netns-0.2.1.ebuild29
-rw-r--r--app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild31
4 files changed, 81 insertions, 0 deletions
diff --git a/app-emulation/slirp4netns/Manifest b/app-emulation/slirp4netns/Manifest
new file mode 100644
index 000000000000..e7cc7a273890
--- /dev/null
+++ b/app-emulation/slirp4netns/Manifest
@@ -0,0 +1,2 @@
+DIST slirp4netns-0.2.1.tar.gz 136425 BLAKE2B 81d6a0e68433522c2382ca938515ff7a96bf9afab32d3b25db454c706f24afb671709bcca6d52b5673934bf1963ec1795f8022319c2f6d936fd17e87e4e3edff SHA512 f923fe7b02eb30a108e99c63574dd1e9e948c9afa56a2747ddb0b78ea24beadecbce93b3644171c3aea698e5d37f4302eb22e4187f14db870b1e8018f75f4089
+DIST slirp4netns-0.3.0_alpha2.tar.gz 157206 BLAKE2B b408fadc322c81efa5985587a5121fbe4e5db5319367946263f721eef3022eec8c9db175f0bac25c2d614107747e39c397385a2c3d264c85266e908b887b9b4c SHA512 f2dd5f2d9d5d82f83ba5a35dc001ebf9413113580dfd44cd96f498100852260662965c0df33f489ce76872e1ec8c884006e6a4e386f2f0094d0e538217cc4ac8
diff --git a/app-emulation/slirp4netns/metadata.xml b/app-emulation/slirp4netns/metadata.xml
new file mode 100644
index 000000000000..2cab48fc0192
--- /dev/null
+++ b/app-emulation/slirp4netns/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>g.braeunlich@disroot.org</email>
+ <name>Gerhard Bräunlich</name>
+ </maintainer>
+ <longdescription lang="en">
+ slirp4netns provides user-mode networking ("slirp")
+ for unprivileged network namespaces.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rootless-containers/slirp4netns</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/slirp4netns/slirp4netns-0.2.1.ebuild b/app-emulation/slirp4netns/slirp4netns-0.2.1.ebuild
new file mode 100644
index 000000000000..c0e3625e200d
--- /dev/null
+++ b/app-emulation/slirp4netns/slirp4netns-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="User-mode networking for unprivileged network namespaces"
+HOMEPAGE="https://github.com/rootless-containers/slirp4netns"
+SRC_URI="https://github.com/rootless-containers/slirp4netns/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+pkg_postinst() {
+ elog "You need to have the tun kernel module loaded in order to have"
+ elog "slirp4netns working"
+}
diff --git a/app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild b/app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild
new file mode 100644
index 000000000000..3dd9a9ad4053
--- /dev/null
+++ b/app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="User-mode networking for unprivileged network namespaces"
+HOMEPAGE="https://github.com/rootless-containers/slirp4netns"
+SRC_URI="https://github.com/rootless-containers/slirp4netns/archive/v${PV/_alpha/-alpha.}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+S="${WORKDIR}/${P/_alpha/-alpha.}"
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+pkg_postinst() {
+ elog "You need to have the tun kernel module loaded in order to have"
+ elog "slirp4netns working"
+}