summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-php')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index a5f7c7d3c47c..be9c960c6460 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -2,3 +2,4 @@ DIST eselect-php-0.7.1.bz2 2251 SHA256 10aa400e2d08bc71989366993f12ddb546a0ea29f
DIST eselect-php-0.8.2.tar.xz 51832 SHA256 3601d0612a19ccc1c5146be2c8cd7df955a37c517817ae4f59bb3ead446f5355 SHA512 da1d71affe275d07db7a76fd98fd89ffdea6f671262a615bf4dda5a1bba8d19e5d1a3c8afe3f1eb1e70fd71298476a6f0d4e73eba7aafe7555f018f89005bc3d WHIRLPOOL dcc75d93eeaaa85f63f5329491d010debd83ed2a82af0051d59ab4aff639703a6f4c1baa5388ed2a8867d6ab610740d5a1ac86d28cddb0de5be47872ada040b4
DIST eselect-php-0.8.5.tar.xz 45800 SHA256 73b1dfab538dad971644ae9542e311cd9160e5dff3947086fc7691f0fedb835d SHA512 dbb97ddca2cd031e57e1efccc2a92dcb7aa3c4a4813c72dc5ad688b8e32e4e2ec8083781c450e9c439a9e70f04c26249e335a4eb814ac944dfc6e2d06ca724f6 WHIRLPOOL 00d8a1b6e065962105b704e8a6ab806c6f8181a4ec4c266902854ce61cb4532063412449c623ea7288e49dd64c4a8b762b9771abb89664071ff81b7b9728a8e5
DIST eselect-php-0.9.1.tar.xz 47548 SHA256 0c9768c9dd361dd3910f26e11956fc2121467ab56c52ba80d7620b1d757bc143 SHA512 bea84b4ae386d60cea2703d1b1c2a91bdc19188dfe151619750a1979dcfbdf2a2ada05d87faa7e0f371ab003e05be6fc7dd15f96459ae6e998c62e6d5caeb64a WHIRLPOOL 3d74edfa6962942836aa3823e9901b461433ce57f2fcb624eb1652b36245599a1bc076db5cb902b675747f2255f00ac887a5e35859dbcf62279944595ea02d6c
+DIST eselect-php-0.9.2.tar.xz 48356 SHA256 8b2acfccb3d2e3d7cad137fc4306711371ebd544cbcdad8e9d46c5dacf8ed889 SHA512 ebf4c9039aaa3ffad79dee181b5cd77f144a4b1b49d80291b290377b7ca5a9618d8b18922f0624e646c4d80266c58199bb936a7b8dd5d2e2bdc296099f583edf WHIRLPOOL 5ca0673a80b5e88522ff1ca82c4b4f842a63439cd47562c72048a4d66dc88d2dcc7070c28c0b8ff50a75bdb1a9056ee5391b37f4dc34cc9eda3652c6791a276c
diff --git a/app-eselect/eselect-php/eselect-php-0.9.2.ebuild b/app-eselect/eselect-php/eselect-php-0.9.2.ebuild
new file mode 100644
index 000000000000..1a9e8bceb7f7
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.9.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+src_configure(){
+ # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+ # that's what PHP upstream expects. See for example the FPM
+ # configuration where they put logs in @localstatedir@/log.
+ econf --localstatedir="${EPREFIX}"/var $(use_enable apache2)
+}
+
+src_install() {
+ default
+
+ # This can be removed after a while...
+ if use apache2 ; then
+ insinto /etc/apache2/modules.d
+ newins "${FILESDIR}/70_mod_php5.backcompat.conf" 70_mod_php5.conf
+ fi
+
+ if use fpm ; then
+ newinitd "doc/php-fpm.example.init" "php-fpm"
+ newconfd "doc/php-fpm.example.conf" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2 ; then
+ elog
+ elog "If you are upgrading, be warned that our mod_php configuration"
+ elog "file has changed! You should now define -DPHP for the apache2"
+ elog "daemon, and inspect the new 70_mod_php.conf which has been"
+ elog "installed. Module loading involves eselect as of this version."
+ elog
+ elog "You must run eselect at least once to choose your apache2 target"
+ elog "before the new configuration will work. Afterwards, and after you"
+ elog "have reviewed your new configuration, you are advised to remove"
+ elog "the obsolete 70_mod_php5.conf file."
+ elog
+ fi
+}