summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-repository/eselect-repository-7.ebuild')
-rw-r--r--app-eselect/eselect-repository/eselect-repository-7.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-eselect/eselect-repository/eselect-repository-7.ebuild b/app-eselect/eselect-repository/eselect-repository-7.ebuild
deleted file mode 100644
index b2093824acb7..000000000000
--- a/app-eselect/eselect-repository/eselect-repository-7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit python-single-r1
-
-DESCRIPTION="Manage repos.conf via eselect"
-HOMEPAGE="https://github.com/mgorny/eselect-repository"
-SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="${PYTHON_DEPS}
- app-admin/eselect
- $(python_gen_cond_dep '
- dev-python/lxml[${PYTHON_MULTI_USEDEP}]
- ')
- net-misc/wget"
-
-src_compile() {
- MAKEARGS=(
- PREFIX="${EPREFIX}/usr"
- SYSCONFDIR="${EPREFIX}/etc"
- SHAREDSTATEDIR="${EPREFIX}/var"
- ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
- )
-
- emake "${MAKEARGS[@]}"
- python_fix_shebang eselect-repo-helper
-}
-
-src_install() {
- emake "${MAKEARGS[@]}" DESTDIR="${D}" install
- keepdir /var/db/repos
- einstalldocs
-}