summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild15
-rw-r--r--app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-9999.ebuild10
2 files changed, 22 insertions, 3 deletions
diff --git a/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild b/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..a8079a2f4223
--- /dev/null
+++ b/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An eselect library to manage executable symlinks"
+HOMEPAGE="https://github.com/mgorny/eselect-lib-bin-symlink/"
+SRC_URI="https://github.com/mgorny/eselect-lib-bin-symlink/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
diff --git a/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-9999.ebuild b/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-9999.ebuild
index b98f185b49cd..208e978f8a02 100644
--- a/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-9999.ebuild
+++ b/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-9999.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils git-r3
+inherit autotools git-r3
DESCRIPTION="An eselect library to manage executable symlinks"
HOMEPAGE="https://github.com/mgorny/eselect-lib-bin-symlink/"
@@ -16,3 +15,8 @@ KEYWORDS=""
IUSE=""
RDEPEND="app-admin/eselect"
+
+src_prepare() {
+ default
+ eautoreconf
+}