summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/honggfuzz/honggfuzz-2.0.ebuild')
-rw-r--r--app-forensics/honggfuzz/honggfuzz-2.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-forensics/honggfuzz/honggfuzz-2.0.ebuild b/app-forensics/honggfuzz/honggfuzz-2.0.ebuild
new file mode 100644
index 000000000000..c6f560e1a1ed
--- /dev/null
+++ b/app-forensics/honggfuzz/honggfuzz-2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A general purpose fuzzer with feedback support"
+HOMEPAGE="http://google.github.io/honggfuzz/"
+SRC_URI="https://github.com/google/honggfuzz/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=sys-libs/binutils-libs-2.29:=
+ sys-libs/libunwind:=
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CHANGELOG
+ COPYING
+ CONTRIBUTING
+ README.md
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-no-werror.patch
+ "${FILESDIR}"/${PN}-1.1-binutils-2.29.patch
+)
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
+}
+
+src_install() {
+ dobin ${PN}
+
+ einstalldocs
+}