summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/rdd')
-rw-r--r--app-forensics/rdd/Manifest1
-rw-r--r--app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch25
-rw-r--r--app-forensics/rdd/metadata.xml16
-rw-r--r--app-forensics/rdd/rdd-3.0.4-r1.ebuild51
4 files changed, 93 insertions, 0 deletions
diff --git a/app-forensics/rdd/Manifest b/app-forensics/rdd/Manifest
new file mode 100644
index 000000000000..cbbe14b641c1
--- /dev/null
+++ b/app-forensics/rdd/Manifest
@@ -0,0 +1 @@
+DIST rdd-3.0.4.tar.gz 5896942 SHA256 13e20e91dbc029a4a4f0713c1a049c94378083a1f3469ef0006e301484040685 SHA512 8f4536cfd8d1f4bb841a40d163b922698e27f02b8aa9f525c265e4c2ebf94bf5e61f8ea8452fca00d5a5ab7977bc24b64288b6442c8076692b045ed9936ba86f WHIRLPOOL 25a5b8032aa6c317d55f83ad745e1c0436aac12655726ce4a1938900bcd34c7cb92d6410159b490800bf8b850658573f3999a15b261539597820aa5360e4ecb3
diff --git a/app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch b/app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch
new file mode 100644
index 000000000000..b7188030fba5
--- /dev/null
+++ b/app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch
@@ -0,0 +1,25 @@
+diff -Naur rdd-3.0.4-orig/src/Makefile.am rdd-3.0.4/src/Makefile.am
+--- rdd-3.0.4-orig/src/Makefile.am 2013-07-26 11:27:50.288696066 -0400
++++ rdd-3.0.4/src/Makefile.am 2013-07-26 12:14:51.601771619 -0400
+@@ -83,14 +83,15 @@
+ rdd-verify.1
+
+ install-exec-local:
+- $(INSTALL) $(srcdir)/rddi.py $(bindir)/rddi
+- $(INSTALL) $(srcdir)/plot-entropy.py $(bindir)/plot-entropy
+- $(INSTALL) $(srcdir)/plot-md5.py $(bindir)/plot-md5
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) $(srcdir)/rddi.py $(DESTDIR)$(bindir)/rddi
++ $(INSTALL) $(srcdir)/plot-entropy.py $(DESTDIR)$(bindir)/plot-entropy
++ $(INSTALL) $(srcdir)/plot-md5.py $(DESTDIR)$(bindir)/plot-md5
+
+ uninstall-local:
+- rm -f $(bindir)/rddi
+- rm -f $(bindir)/plot-entropy
+- rm -f $(bindir)/plot-md5
++ rm -f $(DESTDIR)$(bindir)/rddi
++ rm -f $(DESTDIR)$(bindir)/plot-entropy
++ rm -f $(DESTDIR)$(bindir)/plot-md5
+
+ DISTCLEANFILES= Makefile.in
+
diff --git a/app-forensics/rdd/metadata.xml b/app-forensics/rdd/metadata.xml
new file mode 100644
index 000000000000..dd5f0a448a31
--- /dev/null
+++ b/app-forensics/rdd/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rdd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-forensics/rdd/rdd-3.0.4-r1.ebuild b/app-forensics/rdd/rdd-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..1c117d472b4d
--- /dev/null
+++ b/app-forensics/rdd/rdd-3.0.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+# no worky
+RESTRICT="test"
+
+DESCRIPTION="Rdd is a forensic copy program"
+HOMEPAGE="http://www.sf.net/projects/rdd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-forensics/libewf
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/rdd-3.0.4-sandbox-fix.patch"
+ sed -i 's/AM_PATH_GTK_2_0//' configure.ac || die
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ #doxygen-html fails but the docs are prebuilt so we don't need to enable them
+ econf --disable-doxygen-html \
+ $(use_enable debug tracing) \
+ $(use_enable doc doxygen-doc)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dobin src/rddi.py
+ dosym rdd-copy /usr/bin/rdd
+ #this causes a warning about not being recursive, no clue why
+ dohtml -r doxygen-doc/html/*
+}