summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/qkc/qkc-1.00.ebuild')
-rw-r--r--app-i18n/qkc/qkc-1.00.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/app-i18n/qkc/qkc-1.00.ebuild b/app-i18n/qkc/qkc-1.00.ebuild
index b9877517dd47..164c0c12afa7 100644
--- a/app-i18n/qkc/qkc-1.00.ebuild
+++ b/app-i18n/qkc/qkc-1.00.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
inherit toolchain-funcs
@@ -14,17 +14,15 @@ SRC_URI="http://hp.vector.co.jp/authors/VA000501/${MY_P}.zip"
LICENSE="freedist"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
-IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
+
S="${WORKDIR}"
-src_prepare() {
- sed -i "/^LFLAGS/s:$: \${LDFLAGS}:" Makefile
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {