summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim')
-rw-r--r--app-i18n/scim/Manifest1
-rw-r--r--app-i18n/scim/files/scim-1.4.18-slibtool.patch36
-rw-r--r--app-i18n/scim/metadata.xml2
-rw-r--r--app-i18n/scim/scim-1.4.17.ebuild100
-rw-r--r--app-i18n/scim/scim-1.4.18.ebuild14
5 files changed, 46 insertions, 107 deletions
diff --git a/app-i18n/scim/Manifest b/app-i18n/scim/Manifest
index 13684813add0..3d55a28c3958 100644
--- a/app-i18n/scim/Manifest
+++ b/app-i18n/scim/Manifest
@@ -1,2 +1 @@
-DIST scim-1.4.17.tar.gz 1285383 BLAKE2B 95b9ecb0bb25a15876df8175ee0b9392c301e3b0c554ac6ccba6b863420828ce185d3454f2fef48c03e7451f01815020290be7611b8536d8a028153af3a3fe2b SHA512 a7e0696330bca6fdf929ec0565ab4af1b4d0e5f73592cf5cccf1af6412eb351cd5a5ec9a3e5b83b24d6abad89bbb38a375cbbb0fd978f2fa17f6d64b69da0e3a
DIST scim-1.4.18.tar.gz 1288060 BLAKE2B c2f1ce5608423734899aa6698060245c4ee253048d04d32bf5e853b8c68255340a8d35c0ebaaa50871b07c23ee9018b6bac03b18fbd4fa4dbea0e67c32c9ae30 SHA512 9a6090fc1ab950905a9c54d6678ce3d2a44297d1a992a3e933b0466688638e6cf470c1682daa58a6fbb6de3216b649273faf7edff1ac0ecca1c2c77fc19108fb
diff --git a/app-i18n/scim/files/scim-1.4.18-slibtool.patch b/app-i18n/scim/files/scim-1.4.18-slibtool.patch
new file mode 100644
index 000000000000..b80db440dfd1
--- /dev/null
+++ b/app-i18n/scim/files/scim-1.4.18-slibtool.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/777297
+
+From dea50ce8e57aeb99034b880ee20ed91103e44555 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 19 Mar 2021 10:05:37 -0700
+Subject: [PATCH] build: Fix undefined X11 references.
+
+---
+ extras/immodules/client-gtk/gtk2/Makefile.am | 1 +
+ extras/immodules/client-gtk/gtk3/Makefile.am | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/extras/immodules/client-gtk/gtk2/Makefile.am b/extras/immodules/client-gtk/gtk2/Makefile.am
+index 8192f08..e7a7937 100644
+--- a/extras/immodules/client-gtk/gtk2/Makefile.am
++++ b/extras/immodules/client-gtk/gtk2/Makefile.am
+@@ -41,6 +41,7 @@ im_scim_la_CFLAGS =@GTK2_CFLAGS@
+ im_scim_la_LDFLAGS = -rpath $(moduledir) \
+ -avoid-version -no-undefined \
+ -module \
++ @X_LIBS@ \
+ @GTK2_LIBS@
+
+ im_scim_la_LIBADD = $(top_builddir)/extras/immodules/common/libscimbridgecommon.la \
+diff --git a/extras/immodules/client-gtk/gtk3/Makefile.am b/extras/immodules/client-gtk/gtk3/Makefile.am
+index b868c80..d6f656d 100644
+--- a/extras/immodules/client-gtk/gtk3/Makefile.am
++++ b/extras/immodules/client-gtk/gtk3/Makefile.am
+@@ -41,6 +41,7 @@ im_scim_la_CFLAGS =@GTK3_CFLAGS@
+ im_scim_la_LDFLAGS = -rpath $(moduledir) \
+ -avoid-version -no-undefined \
+ -module \
++ @X_LIBS@ \
+ @GTK3_LIBS@
+
+ im_scim_la_LIBADD = $(top_builddir)/extras/immodules/common/libscimbridgecommon.la \
diff --git a/app-i18n/scim/metadata.xml b/app-i18n/scim/metadata.xml
index 9115a5e98acc..05b68dc37080 100644
--- a/app-i18n/scim/metadata.xml
+++ b/app-i18n/scim/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>cjk@gentoo.org</email>
diff --git a/app-i18n/scim/scim-1.4.17.ebuild b/app-i18n/scim/scim-1.4.17.ebuild
deleted file mode 100644
index 1365db6b815e..000000000000
--- a/app-i18n/scim/scim-1.4.17.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils flag-o-matic multilib gnome2-utils autotools qmake-utils
-
-DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
-HOMEPAGE="https://sourceforge.net/projects/scim"
-SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ppc ppc64 sparc x86"
-IUSE="doc gtk3"
-
-RDEPEND="x11-libs/libX11
- dev-libs/glib:2
- gtk3? ( x11-libs/gtk+:3 )
- !gtk3? ( x11-libs/gtk+:2 )
- >=dev-libs/atk-1
- >=x11-libs/pango-1"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen
- >=app-text/docbook-xsl-stylesheets-1.73.1 )
- dev-lang/perl
- virtual/pkgconfig
- >=dev-util/intltool-0.33
- sys-devel/libtool"
-DOCS=(
- README
- AUTHORS
- ChangeLog
- docs/developers
- docs/scim.cfg
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # bug #83625
- filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
- econf $(use_with doc doxygen) \
- --enable-ld-version-script \
- $(usex gtk3 --with-gtk-version={3,2}) \
- --disable-qt3-immodule \
- --disable-qt4-immodule
-}
-
-src_compile() {
- default
- use doc && emake docs
-}
-
-src_install() {
- use doc && HTML_DOCS=( "${S}/docs/html/" )
- default
-
- sed -e "s:@EPREFIX@:${EPREFIX}:" "${FILESDIR}/xinput-${PN}" > "${T}/${PN}.conf" || die
- insinto /etc/X11/xinit/xinput.d
- doins "${T}/${PN}.conf"
-}
-
-pkg_postinst() {
- elog
- elog "To use SCIM with both GTK and XIM, you should use the following"
- elog "in your user startup scripts such as .gnomerc or .xinitrc:"
- elog
- elog "LANG='your_language' scim -d"
- elog "export XMODIFIERS=@im=SCIM"
- elog "export GTK_IM_MODULE=\"scim\""
- elog "export QT_IM_MODULE=\"scim\""
- elog
- elog "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
- elog "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
- elog
- elog "To use Chinese input methods:"
- elog " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
- elog "To use Korean input methods:"
- elog " # emerge app-i18n/scim-hangul"
- elog "To use Japanese input methods:"
- elog " # emerge app-i18n/scim-anthy"
- elog "To use various input methods (more than 30 languages):"
- elog " # emerge app-i18n/scim-m17n"
- elog
- elog "Please modify ${EPREFIX}/etc/scim/global and add your UTF-8 locale to"
- elog "/SupportedUnicodeLocales entry."
- elog
- ewarn
- ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
- ewarn
-
- gnome2_query_immodules_gtk2
-}
-
-pkg_postrm() {
- gnome2_query_immodules_gtk2
-}
diff --git a/app-i18n/scim/scim-1.4.18.ebuild b/app-i18n/scim/scim-1.4.18.ebuild
index 0cc809f40762..78a49c4912cf 100644
--- a/app-i18n/scim/scim-1.4.18.ebuild
+++ b/app-i18n/scim/scim-1.4.18.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit autotools flag-o-matic gnome2-utils qmake-utils
+inherit autotools flag-o-matic gnome2-utils
DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
HOMEPAGE="https://github.com/scim-im/scim"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/scim-im/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86"
IUSE="doc gtk3"
RDEPEND="x11-libs/libX11
@@ -21,12 +21,12 @@ RDEPEND="x11-libs/libX11
>=dev-libs/atk-1
>=x11-libs/pango-1"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen
+ doc? ( app-text/doxygen
>=app-text/docbook-xsl-stylesheets-1.73.1 )
dev-lang/perl
virtual/pkgconfig
>=dev-util/intltool-0.33
- sys-devel/libtool"
+ dev-build/libtool"
DOCS=(
README
AUTHORS
@@ -35,6 +35,10 @@ DOCS=(
docs/scim.cfg
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.18-slibtool.patch
+)
+
src_prepare() {
default
eautoreconf