summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/unicode-data/unicode-data-9.0.0.ebuild')
-rw-r--r--app-i18n/unicode-data/unicode-data-9.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/unicode-data/unicode-data-9.0.0.ebuild b/app-i18n/unicode-data/unicode-data-9.0.0.ebuild
new file mode 100644
index 000000000000..944ea6e2967b
--- /dev/null
+++ b/app-i18n/unicode-data/unicode-data-9.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Unicode data from unicode.org"
+HOMEPAGE="http://www.unicode.org/ucd/"
+SRC_URI="http://www.unicode.org/Public/zipped/${PV}/UCD.zip
+ http://www.unicode.org/Public/zipped/${PV}/Unihan.zip"
+
+LICENSE="unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # Unihan.zip needs to be installed as a zip for reverse deps
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210
+ unpack UCD.zip
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r "${S}"/*
+ doins "${DISTDIR}"/Unihan.zip
+}