summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-bridge/files/scim-bridge-0.4.16-fixes-send-function-call.patch15
-rw-r--r--app-i18n/scim-bridge/scim-bridge-0.4.16-r3.ebuild3
2 files changed, 17 insertions, 1 deletions
diff --git a/app-i18n/scim-bridge/files/scim-bridge-0.4.16-fixes-send-function-call.patch b/app-i18n/scim-bridge/files/scim-bridge-0.4.16-fixes-send-function-call.patch
new file mode 100644
index 000000000000..fd894441a5a7
--- /dev/null
+++ b/app-i18n/scim-bridge/files/scim-bridge-0.4.16-fixes-send-function-call.patch
@@ -0,0 +1,15 @@
+From Fedora:
+https://src.fedoraproject.org/rpms/scim-bridge/c/0532ab48617e02f5bfb1edaba17b22e88d9beaf4
+Index: scim-bridge-0.4.16/agent/scim-bridge-agent-signal-listener.cpp
+===================================================================
+--- scim-bridge-0.4.16.orig/agent/scim-bridge-agent-signal-listener.cpp
++++ scim-bridge-0.4.16/agent/scim-bridge-agent-signal-listener.cpp
+@@ -64,7 +64,7 @@ static void sig_quit (int sig)
+ {
+ if (!signal_occurred) {
+ signal_occurred = true;
+- send (pipe_in, '\0', sizeof (char), MSG_NOSIGNAL);
++ send (pipe_in, "", sizeof (char), MSG_NOSIGNAL);
+ }
+ }
+
diff --git a/app-i18n/scim-bridge/scim-bridge-0.4.16-r3.ebuild b/app-i18n/scim-bridge/scim-bridge-0.4.16-r3.ebuild
index 09cdd8f522b3..9fe5ab6806ac 100644
--- a/app-i18n/scim-bridge/scim-bridge-0.4.16-r3.ebuild
+++ b/app-i18n/scim-bridge/scim-bridge-0.4.16-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools gnome2-utils readme.gentoo-r1
@@ -42,6 +42,7 @@ PATCHES=(
"${FILESDIR}/${P}+gcc-4.4.patch"
"${FILESDIR}/${P}+gcc-4.7.patch"
"${FILESDIR}/${P}-configure.ac.patch" #280887
+ "${FILESDIR}/${P}-fixes-send-function-call.patch" # 645168
)
src_prepare() {