summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild')
-rw-r--r--app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild b/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..394e35d82ff0
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openrc.patch
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd rcscripts/thinkfan.gentoo ${PN}
+
+ doman ${PN}.1
+ dodoc ChangeLog NEWS README \
+ examples/${PN}.conf.{complex,sysfs,thinkpad}
+}
+
+pkg_postinst() {
+ elog "Please read the documentation and copy an"
+ elog "appropriate file to /etc/thinkfan.conf."
+}